EIGRP TP No 1 : Configuration Basique

Vous voulez apprendre à configurer EIGRP ? Vous êtes au bon endroit.

A travers cet article, nous allons voir plusieurs exercices afin de faire le tour des configurations à connaitre pour une implémentation basique du protocole.

Pour réaliser les TP, je vous recommande GNS3. Vous aurez ainsi accès à toutes les options de configuration.

 

1)     Configuration basique

 

1.1) Topologie à utiliser

Voici la topologie à utiliser pour ce Lab.

Les équipements ont simplement été configurés avec les IP données.

Les interfaces de Loopback servent à symboliser des sous réseaux auxquels le routeur est connecté.

Exemple pour R1 :

–          Loopback 0 : 10.1.0.1 255.255.255.0

–          Loopback 1 : 10.1.1.1 255.255.255.0

–          Etc…

 

Topologie TP EIGRP

1.2 Activation d’EIGRP

Commençons par activer le protocole EIGRP sur les routeurs. Puis nous appliquerons une configuration basique.

R1(config)#router eigrp 90

Le paramètre 90 représente l’Autonomous System. Il doit être le même sur tous les routeurs.

Pour rappel, l’AS est une zone dans laquelle les routeurs peuvent discuter et s’échanger des informations de routage.

Pour communiquer avec un autre AS, il faut mettre en place de la redistribution de route ou bien passer par un protocole de routage externe, comme BGP, ou utiliser des routes statiques, etc…

Pour le moment, nous choisirons un AS égale sur tous les routeurs.

 

Ensuite, la première chose à faire, est de désactiver le résumé automatique des routes :

R1(config-router)#no auto-summary

Le résumé de route est une bonne chose, mais il est préférable de le faire soi-même.
Nous verrons plus tard comment.

 

Il convient ensuite de dire au routeur sur quel réseau il doit opérer.

R1(config-router)#network 172.16.1.0 0.0.0.255

Cette commande va définir quel réseau inclure dans les MAJ EIGRP, et aussi sur quel interface agir (en l’occurrence fa0/0 car elle à une IP dans ce réseau).

Nous pouvons voir que le masque est indiqué sous la forme d’un Wildcard Mask.

Pour rappel, le Wildcard Mask est plus ou moins l’inverse du masque.

Voici comment le calculer :

On soustrait le masque voulu à un masque 4 * 255

Formule de calcul du Wildcard Mask

 

La commande précédente peut aussi être rentrée en spécifiant directement l’IP d’une interface du routeur :

R1(config-router)#network 172.16.2.1 0.0.0.0

 

Il ne reste plus qu’à faire de même sur tous les routeurs.

R2(config)#router eigrp 90
R2(config-router)#no auto-summary
R2(config-router)#network 172.16.1.2 0.0.0.0
R2(config-router)#network 172.16.3.2 0.0.0.0

 

R3(config)#router eigrp 90
R3config-router)#no auto-summary
R3(config-router)#network 172.16.3.3 0.0.0.0
R3(config-router)#network 172.16.2.3 0.0.0.0

 

Bien sûr, il ne faut pas oublier les interfaces de Loopback.

R1(config-router)#network 10.1.0.0 0.0.3.255
R2(config-router)#network 10.2.0.0 0.0.3.255
R3(config-router)#network 10.3.0.0 0.0.3.255

 

Bien, nous avons mis en place de l’EIGRP, et nous lui avons indiqué sur quels réseaux agir.

Normalement, les routeurs devraient avoir rempli leur table de routage.

Voyons cela sur R1 :

Table de routage

Toutes les routes sont présentes.

En jaune, ce sont celles vers R2.

 

Avant de passer à la suite, sachez qu’il est possible d’annoncer une route statique, simplement en l’incluant dans une commande Network.

Par exemple, si R1 a une route statique pour 192.168.150.0 /24

R1(config)#ip route 192.168.150.0 255.255.255.0 Null 0

Il suffit d’inclure ce réseau dans une commande network, pour qu’une route vers 192.168.150.0 /24 soit annoncée.

R1(config)#router eigrp 90
R1(config-router)#network 192.168.150.0

Vous pouvez voir le résultat dans la table de routage de R2 ou R3.

 

1.3) Route Summarization

Que pensez-vous de la table de routage ?

Difficile à lire, non ?

Voyons donc comment mettre en place des résumés de route, manuellement (ou Route Summarization).

Le but est que les routeurs n’annoncent plus tous les réseaux 10.0.0.0 /8.

Par exemple, R1 n’annoncera qu’une route : 10.1.0.0 /22

L’ajout de routes résumées se fait sur les interfaces.

Voici pour R1 :

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip summary-address eigrp 90 10.1.0.0 255.255.252.0

En paramètre de la commande, il y a :

–          L’AS

–          L’IP du réseau à résumer

–          Le masque

10.1.0.0 /22 couvre le range d’IP allant de 10.1.0.0 à 10.1.3.255.

Il faut maintenant faire de même sur fa0/1

R1(config)#interface fastEthernet 0/1
R1(config-if)#ip summary-address eigrp 90 10.1.0.0 255.255.252.0

 

Allons voir le résultat sur R2 :

Table de routage

Il n’y a plus qu’une seule route pour 10.1.0.0.

Il s’agit bien de la route résumée.

 

Faisons de même sur R2 et R3.

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip summary-address eigrp 90 10.2.0.0 255.255.252.0
R2(config)#interface fastEthernet 0/1
R2(config-if)#ip summary-address eigrp 90 10.2.0.0 255.255.252.0
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip summary-address eigrp 90 10.3.0.0 255.255.252.0
R3(config)#interface fastEthernet 0/1
R3(config-if)#ip summary-address eigrp 90 10.3.0.0 255.255.252.0

Vérifions le tout :

Table de routage

Les routes envoyées par R2 et R3 sont bien résumées !

 

1.4) Passive Interface

Afin de sécuriser nos routeurs, il est préférable de mettre en place des Passive Interfaces.

Vous avez peut-être déjà pu en mettre en place sur d’autres protocoles.

Mais les Passive Interfaces fonctionnent un peu différemment en EIGRP.

Elles ne servent pas qu’à bloquer l’envoie de MAJ de routage, mais aussi à empêcher la réception de MAJ sur les interfaces passives.

Voici le détail des fonctionnalités d’une Passive Interface :

–          N’envoie pas de MAJ de routage

–          N’envoie pas de Hello, donc pas de relation de voisinage

–          Ignore les MAJ et Hello entrant

–          Si l’interface est inclue dans une commande  « Newtork », le réseau auquel elle appartient est toujours annoncé dans les MAJ (mais pas par cette interface).

Les interfaces passives sont donc à activer sur toutes les interfaces qui ne sont pas reliées à un voisins EIGRP.

 

Voici comment les configurer :

R1(config)#router eigrp 90
R1(config-router)#passive-interface loopback 0

Ceci est la configuration basique.

Pour plus de sécurité, et pour une configuration plus simple, le mieux est de mettre toutes les interfaces en mode Passive, sauf celles choisies.

Comme ceci :

R1(config-router)#passive-interface default
R1(config-router)#no passive-interface fastEthernet 0/0
R1(config-router)#no passive-interface fastEthernet 0/1

Ainsi, seules les interfaces choisies feront partie du processus EIGRP.

Attention tout de même, une fois la commande « passive-interface default » entrée sur le routeur, les relations de voisinage vont automatiquement être perdues. Le temps de passer les commandes « no passive-interface … », le routeur ne pourra plus joindre ses voisins pour router des paquets.

Il en résulte donc une interruption de service.

Faites donc preuve de prudence si vous appliquez cette configuration sur un environnement en production.

 

Appliquons maintenant la même configuration sur R2 et R3.

R2(config-router)#passive-interface default
R2(config-router)#no passive-interface fastEthernet 0/0
R2(config-router)#no passive-interface fastEthernet 0/1

 

R3(config-router)#passive-interface default
R3(config-router)#no passive-interface fastEthernet 0/0
R3(config-router)#no passive-interface fastEthernet 0/1

 

Voilà, il n’est plus possible de créer de relation de voisinage sur des interfaces autres que Fa0/0 et Fa0/1. Et même si une MAJ EIGRP arrive sur une interface autre que Fa0/0 et Fa0/1, elle est ignorée.

 

Néanmoins, les réseaux derrière les interfaces Loopback sont toujours inclus dans les MAJ (grâce à la commande « Network »).

 

1.5) Load Balancing

Nous avons vu qu’EIGRP permet de faire du Load Balancing en utilisant des liens de métrique égales. Ce type de Load Ballancing se fait automatiquement. Nous verrons apparaitre 2 Next Hop dans la table de routage.

Mais nous avons aussi vu qu’EIGRP propose de faire de l’Unequal Cost Load Balancing. Ce dernier ne se fait pas automatiquement.

Heureusement, la configuration est très simple.

La voici pour R1 :

R1(config)#router eigrp 90
R1(config-router)#variance 2

 

Le paramètre 2 signifie que le routeur peut utiliser des liens 2 fois pire pour faire du Load Balancing.

Les valeurs vont de 1 à 128.

Attention, pour qu’un chemin soit choisi pour faire de l’Unequal Cost Load Balancing, il faut déjà que ce chemin soit un Feasible Successor.

 

Le problème sur notre topologie actuelle, c’est que tous les liens ont la même métrique.

Prenons l’exemple de R1 qui veut une route pour 10.2.0.0 /22 (c’est-à-dire R2). Il ne choisira jamais R3 comme FS.

 

Pour les besoins de cette démonstration, nous allons donc simuler un lien de meilleure bande passante entre R2 et R3.

Voici comment :

R2(config)#interface fastEthernet 0/1
R2(config-if)#bandwidth 150000

 

R3(config)#interface fastEthernet 0/1
R3(config-if)#bandwidth 150000

 

Cette commande ne modifie pas réellement la bande passante du lien. Elle a seulement une influence sur le calcul de la métrique du lien.

Le protocole va donc donner une meilleure métrique au lien.

 

Si l’on affiche la Topologie Table de R1, nous pouvons voir R3 comme FS pour 10.2.0.0 /22

EIGRP Topology Table

Nous avons donc configuré la variance et changé la bande passante d’un lien pour que R3 devienne le Feasible Successor.

 

Mais pour que l’Unequal Cost Load Ballancing soit activé, il faut recréer les relations de voisinage.

R1#clear ip eigrp 90 neighbors

 

Une fois les relations de nouveau en place, nous voyons la répartition de charge effective :

Table de routage

R1 va donc choisir entre R2 et R3 pour la destination 10.2.0.0 /22

Il en est de même pour 10.3.0.0 /22

 

Pour améliorer encore l’Unequal Cost Load Balancing, il est possible de régler la façon donc le routeur choisi les liens.

R1(config-router)#traffic-share balanced

Ainsi, le routeur va répartir les paquets sur les liens, en fonction de la métrique.

Par exemple, pour que R1 joigne 10.2.0.0 /22, si le lien R1 – R2 est deux fois meilleur que le lien R1 – R3 – R2, alors le routeur enverra deux fois plus de paquet sur R1 – R2 que sur R1 – R3 – R2.

SI le lien R1 – R2 a une métrique 3 fois meilleure, le routeur y enverra 3 fois plus de paquet.

Par contre, si le lien n’a pas une métrique au moins deux fois meilleure, le routeur envoie autant de paquet sur R1 – R2 que sur R1 – R3 – R2.

 

En bref, quand R1 cherche à joindre 10.2.0.0 /22, il a le choix entre aller ver R2 ou vers R3.

 

2)     Conclusion

 

Nous arrivons au terme de ce premier article sur la mise en place du protocole EIGRP.

Nous avons pu voir la configuration basique, le résumé de route, les passives interfaces (pour la sécurité) ainsi que le Load Balancing.

Dans le prochain article, nous aborderons des notions un peu plus avancées.

 

 

Tagués avec : , , ,
Publié dans EIGRP

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.