Guide de Configuration – Cisco – Routeur

Dans cet article, vous retrouverez une liste de commandes de configuration du routage pour les routeurs Cisco.

Quelques rapides explications seront données.

 

EIGRP

 

Articles sur l’EIGRP :

http://www.networklab.fr/category/ccnp_routing/eigrp/

 

Configuration basique

 

Pour rentrer en mode de configuration EIGRP, il faut spécifier le numéro d’Autonomous System.

Ce numéro doit être le même sur tous les routeurs.

Pour communiquer avec un autre AS, il faut mettre en place de la redistribution de route ou bien passer par un protocole de routage externe, comme BGP, ou utiliser des routes statiques, etc…

Routeur(config)#router eigrp 90

 

Ensuite, il est important de désactiver le résumé de route automatique.

Cela permet d’éviter bien des problèmes.

Routeur(config-router)#no auto-summary

 

Si vous souhaitez résumer des routes, l’idéal est de faire du résumé manuel.

 

Ensuite, il faut spécifier les réseaux à prendre en charge en EIGRP.

Cela permet de créer les relations de voisinage et d’intégrer des réseaux dans le processus EIGRP.

Routeur(config-router)#network 172.30.0.0 0.0.255.255

Ici, c’est un Wildcardmask qui est utilisé.

 

La commande peut aussi être passée en spécifiant l’IP d’une interface du routeur.

Routeur(config-router)#network 172.30.1.254 0.0.0.0

Personnellement, je trouve cette configuration plus propre.

 

Passive Interface

 

Il est possible de couper l’envoi de message EIGRP en mettant en place des interfaces passives.

Routeur(config-router)#passive-interface serial 0/0

 

Il est aussi possible de mettre toutes les interfaces en passif, sauf celles voulues.

Routeur(config-router)#passive-interface default
Routeur(config-router)#no passive-interface serial 0/0
Routeur(config-router)#no passive-interface serial 0/1 

 

Annonce de route statique

 

Pour annoncer une route statique en EIGRP, il suffit d’utiliser la commande Network.

Exemple pour la route :

Routeur(config)#ip route 192.168.150.0 255.255.255.0 fa0/0
Routeur(config-router)#network 192.168.150.0

 

Résumé de route

 

Le résumé de route se fait directement sur les interfaces.

Routeur(config)#interface fastEthernet 0/0
Routeur(config-if)#ip summary-address eigrp 90 10.1.0.0 255.255.252.0

Ici, 10.1.0.0 est le réseau à résumer, suivi du masque.

Il faut faire cela pour toutes les interfaces qui doivent annoncer la route résumée.

 

Load Ballancing

 

Par défaut, EIGRP fait du Load Ballancing s’il a deux liens équivalent à disposition.

Mais EIGRP est aussi capable de faire de l’Unequal Cost Load Ballancing.

Cela nécessite une configuration particulière.

Routeur(config)#router eigrp 90
Routeur(config-router)#variance 2

Variance 2 indique que le routeur peut utiliser des liens alternatifs, jusqu’à 2 fois moins bons.

La valeur max est 128.

 

Pour une bonne répartition du trafic, utiliser la commande :

Routeur(config-router)#traffic-share balanced

Cela permet de faire une répartition équitable.

 

Authentification

 

En EIGRP, l’authentification se configure comme ceci :

Routeur(config)#key chain EIGRP_KEYS
Routeur(config-keychain)#key 1
Routeur(config-keychain-key)#key-string cisco1
Routeur(config-keychain-key)#accept-lifetime 00:00:00 1 jan 2010 infinite
Routeur(config-keychain-key)#send-lifetime 00:00:00 1 jan 2010 infinite

Routeur(config)#interface serial 0/0.1
Routeur(config-if)#ip authentication mode eigrp 25 md5
Routeur(config-if)#ip authentication key-chain eigrp 25 EIGRP_KEYS

Il faut d’abord créer une Key Chain, comprenant une ou plusieurs clés.
L’Accept-Lifetime correspond à l’intervalle de temps où la clé est acceptée par le routeur.

Le Send Lifetime correspond à l’intervalle de temps où la clé peut être envoyée.

Attention, il faut que la date soit bien configurée.

Ensuite, la Key Chain s’applique sur une interface.

 

Stub

 

En EIGRP, la configuration Stub est simple.

Routeur(config)#router eigrp 1
Routeur(config-router)#eigrp stub

Il existe différentes options qu’il est possible rajouter à la commande par défaut.

 

Redistribution

 

En EIGRP, pour redistribuer des réseaux, il faut spécifier les métriques.

Routeur(config)#router eigrp 100
Routeur(config-router)#redistribute ospf 1 metric 100 100 100 100 100

 

Restriction bande passante

 

Enfin, pour configurer la bande passant utilisable par EIGRP pour l’échange, la commande est celle-ci :

Routeur(config-if)#ip bandwidth-percent eigrp 25 80

 

OSPF

 

Articles sur l’OSPF :

http://www.networklab.fr/category/ccnp_routing/ospf/

 

Configuration basique

 

La configuration basique est la suivante.

Routeur(config)#router ospf 1
Routeur(config-router)#router-id 1.1.1.1
Routeur(config-router)#network 172.16.1.1 0.0.0.0 area 10
Routeur(config-router)#network 172.16.2.1 0.0.0.0 area 10

Ici, 10 correspond au numéro de l’area.

 

Résumé de route

 

Le résumé de route se fait comme ceci.

Routeur(config)#router ospf 1
Routeur(config-router)#area 20 range 10.20.0.0 255.255.252.0

 

Election DR / BDR

 

Il est possible d’influencer l’élection DR/BDR en changeant la priorité.

Routeur(config)#interface fastEthernet 0/0
Routeur(config-if)#ip ospf priority 200

A “0”, le routeur ne peut pas devenir DR/BDR.

La priorité la plus haute gagne.

 

Virtuals Links

 

Les Virtuals Links permettent de relier une zone à la zone 0, quand ces areas ne sont pas voisines.

Dans l’exemple, nous définissons 3 zones :

  • La zone 0
  • La zone intermédiaire, 60
  • La zone finale, qui n’est pas directement reliée à la zone 0

Ici, R3 est dans les zones 0 et intermédiaires

R6 est dans les zones intermédiaire et finale.

R3(config)#router ospf 1
R3(config-router)#area 60 virtual-link 6.6.6.6

R6(config)#router ospf 1
R6(config-router)#area 60 virtual-link 3.3.3.3

 

Stub Area

 

Une Stubby Area permet d’empêcher les LSA de type 4 et 5 de circuler au sein de cette zone.

La configuration est à faire sur tous les routeurs de la zone.

R2(config)#router ospf 1
R2(config-router)#area 40 stub

En échange, les routeurs obtiennent une route par défaut.

 

La Totally Stubby Area permet de faire de même avec les LSA de type 3, 4 et 5.

Le routeur qui fait le lien avec la zone 0 se configure comme ceci :

R2(config)#router ospf 1
R2(config-router)#area 50 stub no-summary

 

Les autres comme cela :

R5(config)#router ospf 1
R5(config-router)#area 50 stub

 

La Not So Stubby Area est une Stubby Area qui permet la redistribution de route depuis cette zone (depuis un ASBR).

Tous les routeurs de la zone se configurent comme ceci :

R2(config)#router ospf 1
R2(config-router)#area 40 nssa

 

Sur le routeur qui fait le lien entre la Backbone Area (Area 0) et la Not So Stubby Area, il faut ajouter la configuration suivante.

R2(config)#router ospf 1
R2(config-router)#area 40 nssa default-information-originate

 

La Totally Stubby Not So Stubby Area fait de même mais pour la Totally Stubby Area.

 

Par rapport à la Not So Stubby Area, seule la configuration du routeur faisant le lien entre la zone et la Backbone Area change.

R2(config-router)#area 40 nssa no-summary

 

Authentication

 

En OSPF, l’authentification se configure au niveau des interfaces.

Routeur(config)#interface fastEthernet 0/0
Routeur(config-if)#ip ospf authentication message-digest
Routeur(config-if)#ip ospf message-digest-key 1 md5 cisco

Le numéro de clé choisie (ici 1) doit être le même sur les deux routeurs.

 

Réseau NBMA, P2M, P2MNB, P2P, Broadcast

 

Sur un réseau NBMA, en plus de la configuration basique d’OSPF, il faut créer les relations de voisinage à la main.

R1(config-router)#neighbor 172.16.0.2
R1(config-router)#neighbor 172.16.0.3

 

Quant aux routeurs qui ne doivent pas devenir, DR/BDR, il faut leur changer la priorité.

R2(config)#interface serial 0/0
R2(config-if)#ip ospf priority 0

 

Sur un réseau Point to Multipoint, il faut passer OSPF en mode Point to Multipoint.

R1(config)#interface serial 0/1
R1(config-if)#ip ospf network point-to-multipoint

 

Sur un réseau Point to Multipoint Non-Broadcast, il faut passer OSPF en mode Point to Multipoint Non-Broadcast.

R1(config)#interface serial 0/1
R1(config-if)#ip ospf network point-to-multipoint non-broadcast

 

Il faut ensuite créer les relations de voisinage à la main.

R1(config)#router ospf 1
R1(config-router)#neighbor 172.16.10.4

 

Sur un réseau Point to Point, il n’y a pas de configuration spéciale.

 

Sur un réseau Broadcast, il faut passer OSPF en mode Broadcast.

R3(config)#interface serial 0/1.1
R3(config-subif)#ip ospf network broadcast

 

Redistribution

 

Pour la redistribution en OSPF, il y a deux options importantes.

  • Subnet: qui permet de ne pas résumer les routes redistribuées.
  • Metric-Type: qui permet de choisir si la métrique doit augmenter après la redistribution (type 1) ou si elle doit toujours rester la même (type 2).
R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 100 subnets metric-type 2 metric 50

 

Si aucune métrique n’est spécifiée, une métrique de 20 sera utilisée.

 

BGP

 

Articles sur BGP :

http://www.networklab.fr/category/ccnp_routing/bgp/

 

Configuration basique

 

Pour entrer en mode de configuration BGP, il faut spécifier le numéro d’AS.

R1(config)#router bgp 300

 

Ensuite, il faut créer à la main les relations de voisinage.

R1(config-router)#neighbor 14.0.0.4 remote-as 100

 

Pour que les réseaux soient annoncés, il faut les ajouter dans le processus BGP.

R1(config-router)#network 50.1.1.0 mask 255.255.255.0

Attention, BGP ne peut annoncer que les routes présentes dans sa table de routage.

 

Relation iBGP et eBGP

 

Pour configurer une relation iBGP, il suffit d’ajouter un voisin ayant un numéro d’AS équivalent à l’AS du routeur local.

R1(config)#router bgp 300
R1(config-router)#neighbor 10.0.23.3 remote-as 300

 

Attention, en iBGP le routeur ne change pas la Next-Hop Address par son adresse au moment où il annonce la route.

Si le routeur qui reçoit la route ne sait pas comment joindre le Next-Hop, cela pose problème.

Pour pallier à cela, il faut ajouter une commande.

R3(config-router)#neighbor 1.1.1.1 next-hop-self

 

Si votre réseau comporte des liens redondants, il est conseillé d’établir les relations iBPG sur des IP de Loopback.

Bien entendu, il faut que les IP de Loopback soient connues par les autres routeurs.

R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config)#router ospf 1
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0

R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config)#router ospf 1
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0

R1(config)#router bgp 300
R1(config-router)#neighbor 3.3.3.3 remote-as 300
R1(config-router)#neighbor 3.3.3.3 update-source loopback 0

R3(config)#router bgp 300
R3(config-router)#neighbor 1.1.1.1 remote-as 300
R3(config-router)#neighbor 1.1.1.1 update-source loopback 0

Il est aussi possible d’établir des relations eBGP sur des IP de Loopback (utile si vous avez un lien redondant vers ce voisin eBGP).

La configuration est semblable, mais il faut ajouter une commande en plus.

R3(config-router)#neighbor 5.5.5.5 ebgp-multihop 2

 

Cette commande est nécessaire, car par défaut une relation eBGP ne peut être établie sur une distance de plus de 1 saut.

 

Les attributs

 

L’attribut Weight permet de préférer un voisin à un autre en cas de chemin redondant pour une même destination.

Le poids le plus haut l’emporte.

Le poids est un attribut local, il n’est pas annoncé aux voisins.

R1(config)#router bgp 100
R1(config-router)#neighbor 3.3.3.3 weight 50

 

L’attribut Local Preference permet de choisir un routeur favori dans l’AS.

Cet attribut n’est pas annoncé hors de l’AS.

Le plus haut gagne.

R3(config)#router bgp 100
R3(config-router)#bgp default local-preference 200

 

L’attribut MED est utile si un routeur possède plusieurs liens vers un AS.

Ce routeur aura le choix du lien à utiliser pour envoyer un message dans l’AS.

L’attribut MED permet d’influencer le choix.

Le MED le plus faible l’emporte.

S’il y a deux routeurs pour entrer dans l’AS, pour privilégier le routeur 1, il faut augmenter la métrique sur le routeur 2.

R2(config)#router bgp 100
R2(config-router)#default-metric 200

Pour modifier les attributs seulement pour certains réseaux, il faut utiliser des Route Maps.

Premièrement, créer une ACL pour les réseaux concernés.

R2(config)#access-list 1 permit 10.1.13.0 0.0.0.255

 

Ensuite, créer la Route Map et configurer l’attribut voulu.

R2(config)#route-map R2_MED
R2(config-route-map)#match ip address 1
R2(config-route-map)#set metric 200

R2(config)#route-map R2_MED permit 20
R2(config-route-map)#exit

 

Enfin, appliquer le Route Map.

R2(config)#router bgp 100
R2(config-router)#neighbor 4.4.4.4 route-map R2_MED out

 

La Route Map peut être configurée en entrée ou en sortie.

 

Path Control

 

Article sur le Path Control :

http://www.networklab.fr/path-control/

 

Choix du Next Hop

 

Dans certains cas, il peut être intéressant de choisir le Next Hop pour certaines destinations.

Pour cela, il faut utiliser une Route Map.

 

Première étape, créer une ACl pour la ou les destinations voulues.

Routeur(config)#ip access-list extended CLIENT1
Routeur(config-ext-nacl)#permit ip host 192.168.1.10 any

 

Ensuite, créer une Route Map qui utilise l’ACL et force le Next Hop.

Routeur(config)#route-map POLICY 10
Routeur(config-route-map)#match ip address CLIENT1
Routeur(config-route-map)#set ip next-hop 201.1.1.2

 

Il faut ensuite créer une deuxième entrée pour les destinations non concernées par l’ACL.

Cette entrée peut être vide, ou bien un Next Hop peut est défini.

Routeur(config)#route-map POLICY 20
Routeur(config-route-map)#set ip next-hop 201.1.1.2

 

Enfin, il faut appliquer la Route Map.

Routeur(config)#interface fa 0/0
Routeur(config-if)#ip policy route-map POLICY

 

IP SLA

 

L’IP SLA peut être utilisé pour vérifier la disponibilité d’une machine, d’un lien, etc…

Par exemple, si un routeur possède un lien + un lien de secours, nous pouvons utiliser l’IP SLA pour vérifier la disponibilité du lien principal.

S’il n’est plus disponible, nous utiliserons le lien de secours.

 

Première étape, créer un objet SLA.

Routeur(config)#ip sla monitor 10
Routeur(config-sla-monitor)#type echo protocol ipIcmpEcho 10.1.1.1
Routeur(config-sla-monitor-echo)#timeout 1000
Routeur(config-sla-monitor-echo)#frequency 3

 

Deuxièmement, définir la date de début et de fin.

Routeur(config)#ip sla monitor schedule 10 start-time now life forever

 

Puis créer un objet de tracking qui utilise l’objet SLA.

Routeur(config)#track 1 rtr 10 reachability

 

Puis créer une ACL pour les réseaux devant être redirigés.

Routeur(config)#ip access-list extended ROUTER
Routeur(config-ext-nacl)#permit ip any any

 

Par la suite, créer une Route Map qui reprend le tout.

Routeur(config)#route-map ROUTER_TRAFFIC permit 10
Routeur(config-route-map)#match ip address ROUTER
Routeur(config-route-map)#set ip next-hop verify-availability 10.1.1.1 10 track 1
Routeu (config-route-map)#set ip next-hop 10.2.2.2

 

L’entrée “set ip next-hop 10.2.2.2” défini le chemin de secours.

 

Enfin appliquer la Route Map.

Routeur(config)#ip local policy route-map ROUTER_TRAFFIC

 

 Redistribution de route

 

Articles sur la redistribution de route :

http://www.networklab.fr/category/ccnp_routing/route-redistribution/

 

Pour contrôler la redistribution de route, il est possible d’utiliser une Distribution List.

 

La configuration est simple.

Premièrement, il faut créer une ACL qui autorise ou non certains réseaux.

R2(config)#access-list 1 permit 172.16.30.0 0.0.0.255
R2(config)#access-list 1 permit 172.16.31.0 0.0.0.255

 

Ensuite, il faut appliquer cette Redistribution List.

R2(config)#router eigrp 1
R2(config-router)#distribute-list 1 out

 

La Prefix List permet aussi de contrôler la redistribution.

Voici un exemple :

R2(config)#ip prefix-list PL_EIGRP-To-OSPF seq 10 permit 172.16.20.0/21 ge 24 le 26

PL_EIGRP-To-OSPF est le nom de la Prefix List.

Seq 10 est le numéro de séquence.

Il est possible de créer plusieurs entrées pour une Prefix List, comme pour une ACL.

Permit 172.16.20.0/21 signifie que les réseaux compris dans 172.16.20.0/21 peuvent être redistribués.

Ge 24 est une option facultative. Elle signifie que le masque de la route à redistribuer, doit être au moins un /24.

Le 26 est une option facultative. Elle signifie que le masque de la route à redistribuer, doit être au plus un /26.

 

Puis on applique la Prefix List.

R2(config)#router ospf 1
R2(config-router)#distribute-list prefix PL_EIGRP-To-OSPF out

 

Enfin, il est possible d’utiliser une Route Map pour contrôler la redistribution.

On commence par définir une ACL.

R2(config)#access-list 1 permit 10.4.0.0 0.0.0.255
R2(config)#access-list 1 permit 10.4.1.0 0.0.0.255

 

Puis on définit la Route Map avec les attributs voulus.

R2(config)#route-map EIGRP-TO-OSPF permit 10
R2(config-route-map)#match ip address 1
R2(config-route-map)#set metric 50
R2(config-route-map)#set metric-type type-2

 

Pour tous les réseaux non concernés par l’ACL, nous pouvons créer une deuxième entrée, avec des attributs différents.

R2(config)#route-map EIGRP-TO-OSPF 20
R2(config-route-map)#set metric 100
R2(config-route-map)#set metric-type type-2

 

Enfin, nous pouvons appliquer la Route Map.

R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 1 subnets route-map EIGRP-TO-OSPF

 

Gateway Redundancy

 

Articles sur le Gateway Redundancy :

http://www.networklab.fr/category/ccnp_switch/gateway_redundancy/

 

HSRP

 

HSRP est propriétaire Cisco.

Le HSRP permet d’associer 2 routeurs, de manière à fournir de la redondance sur la passerelle.

Le deuxième routeur prendra le relai en cas de panne du premier.

Si l’on ajoute plus de routeurs au processus, ils seront en mode Listen.

 

La configuration se fait comme ceci.

Routeur(config)#interface fa0/0
Routeur (config-if)#ip address 10.0.10.2 255.255.255.0
Routeur (config-if)#standby 1 ip 10.0.10.1
Routeur (config-if)#standby 1 priority 150
Routeur (config-if)#standby 1 preempt
Routeur (config-if)#standby 1 timers msec 150 msec 600
Routeur (config-if)#standby 1 authentication md5 key-string NetworkLab

Le routeur avec la priorité la plus haute gagne l’élection du routeur Active, sinon c’est la plus haute IP.

L’option Preempt permet à un routeur de reprendre son rôle quand il revient en ligne après une panne.

Il est possible de personnaliser les Timers pour plus ou moins de réactivité.

 

Il faut faire une configuration équivalente sur un autre routeur.

 

VRRP

 

VRRP est similaire, mais il est standard.

Il peut y avoir deux routeurs ensemble.

 

La configuration est de ce type :

Routeur(config)#interface fa0/0
Routeur(config-if)#ip address 10.0.10.2 255.255.255.0
Routeur(config-if)#vrrp 1 ip 10.0.10.1
Routeur(config-if)#vrrp 1 priority 150
Routeur(config-if)#vrrp 1 preempt
Routeur(config-if)#vrrp 1 timers advertise msec 150

 

GLBP

 

Le GLBP est propriétaire Cisco.

Il permet de répartir la charge.

La configuration se fait comme ceci :

Routeur(config)#interface fastEthernet 0/0
Routeur(config-if)#ip address 10.0.10.2 255.255.255.0
Routeur(config-if)#glbp 1 ip 10.0.10.1
Routeur(config-if)#glbp 1 priority 150
Routeur(config-if)#glbp 1 preempt
Routeur(config-if)#glbp 1 load-balancing round-robin

 

La priorité permet d’influencer l’élection de l’AVG.

C’est le routeur chargé de répondre aux requêtes ARP.

La priorité ne rentre pas en ligne de compte pour la répartition de la charge.

 

Il suffit d’avoir une configuration de ce type (hors priorité).

La charge peut être répartie sur 4 routeurs maximum.

 

 

Tagués avec :
Publié dans Routeur

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.