OSPF Sur Un Réseau NBMA : Configuration

Si vous avez bien compris comment fonctionnent les 5 modes d’OSPF en NBMA, le plus dur est fait.

Reste maintenant à voir comment se configurent ces modes.

A travers ce TP, nous allons revenir sur la configuration des 5 modes d’OSPF sur un réseau NBMA.

 

1)     La topologie

 

Voici la topologie qui sera utilisée :

Topologie OSPF

 

Oui, c’est une grande topologie pour un Lab !

Nous retrouvons 4 zones. Chacune fonctionne sur un mode différent :

Area 0 : NBMA

Area 10 : Point to Multipoint Broadcast (nous verrons aussi comment se configure le mode NonBroadcast)

Area 20 : Point to Point

Area 30 : Broadcast. A note qu’ici, la topologie est du type FullMesh (voir les DLCI)

 

Les routeurs sont reliés entre eux par des switchs Frame Relay.

Ceux-ci sont disponibles dans GNS3.

Pour les configurer, aller dans le menu de configuration, et ajouter des DLCI en suivant le schéma.

Exemple pour FR1 (dans la zone 0) :

Configuration Switch Frame Relay GNS3

Les IP sont données sur le schéma.

Chaque zone correspond à un sous réseau. Le dernier octet de l’IP, correspond au numéro du routeur.

Exemple :

R1 s0/0 : 172.16.0.1

R5 s0/0 : 172.16.10.5

Etc…

 

Enfin, certains routeurs possèdent des interfaces de Loopback, pour simuler des réseaux auquels ils seraient connectés.

 

Avant de passer à la suite, veillez à ce que votre topologie soit bonne, est que les routeurs aient les IP de Loopback.

Nous ferons le reste de la configuration ensemble (interfaces, Frame Relay, OSPF, etc…)

Si votre topologie est prête, passons à la suite !

 

2)     Configuration basique

 

Nous allons voir ici comment mettre en place la configuration de base. C’est-à-dire, la configuration des IP et de Frame Relay. Ainsi, aux seins de nos zones les routeurs pourront se joindre.
Pour établir la communication entre les zones, il faudra mettre en place OSPF (ce que nous feront dans un deuxième temps).

Suivez attentivement les configurations. Il est important de bien comprendre comment fonctionnent les zones (NBMA, Point to Point, etc…). Ainsi, vous comprendrez l’utilité et le fonctionnement des différents modes d’OSPF.

 

Area 0

Voici la configuration à appliquer à R1 (IP + frame Relay) :

R1(config)#interface serial 0/0
R1(config-if)#no shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#ip address 172.16.0.1 255.255.255.0
R1(config-if)#frame-relay map ip 172.16.0.2 102  broadcast
R1(config-if)#frame-relay map ip 172.16.0.3 103  broadcast

 

Pour R2 :

R2(config)#interface serial 0/0
R2(config-if)#no shutdown
R2(config-if)#encapsulation frame-relay
R2(config-if)#ip address 172.16.0.2 255.255.255.0
R2(config-if)#frame-relay map ip 172.16.0.1 201  broadcast
R2(config-if)#frame-relay map ip 172.16.0.3 201  broadcast

 

Il est important de dire à R2 comment joindre R3. Ici, il utilisera le même DLCI que pour joindre R1.

Ce qui fait que,quand R2 veux joindre R3, le message passe par R1.

Nous avons donc une topologie Hub And Spoke (ou en étoile).

 

Pour R3 :

R3(config)#interface serial 0/0
R3(config-if)#no shutdown
R3(config-if)#encapsulation frame-relay
R3(config-if)#ip address 172.16.0.3 255.255.255.0
R3(config-if)#frame-relay map ip 172.16.0.1 301  broadcast
R3(config-if)#frame-relay map ip 172.16.0.2 301  broadcast

 

Si vous avez bien configurer vos routeurs, ils devraient être capables de se joindre

Ping vers R3

 

Area 10

Cette zone se configure comme la précédente.

 

Voici pour R1 (attention à bien utiliser s0/1) :

R1(config)#interface serial 0/1
R1(config-if)#no shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#frame-relay map ip 172.16.10.4 104 broadcast
R1(config-if)#frame-relay map ip 172.16.10.5 105 broadcast

 

R4 :

R4(config)#interface serial 0/0
R4(config-if)#no shutdown
R4(config-if)#encapsulation frame-relay
R4(config-if)#ip address 172.16.10.4 255.255.255.0
R4(config-if)#frame-relay map ip 172.16.10.1 401 broadcast
R4(config-if)#frame-relay map ip 172.16.10.5 401 broadcast

 

R5 :

R5(config)#interface serial 0/0
R5(config-if)#no shutdown
R5(config-if)#encapsulation frame-relay
R5(config-if)#ip address 172.16.10.5 255.255.255.0
R5(config-if)#frame-relay map ip 172.16.10.1 501 broadcast
R5(config-if)#frame-relay map ip 172.16.10.4 501 broadcast

 

Quand tout est bon, tester avec des Ping :

Ping vers R5

 

Area 20

Ici, les liens sont en point to point

 

Voici la configuration de R2 :

R2(config)#interface serial 0/1
R2(config-if)#no shutdown
R2(config-if)#encapsulation frame-relay

 

Voici celle de R6 :

R6(config)#interface serial 0/0
R6(config-if)#no shutdown
R6(config-if)#encapsulation frame-relay

 

R6(config-if)#interface serial 0/0.1 point-to-point
R6(config-subif)#ip address 172.16.20.6 255.255.255.0
R6(config-subif)#frame-relay interface-dlci 602

 

Une fois cela fait, les deux routeurs devraient pouvoir se joindre :

Ping vers R2

 

Area 30

Finissons par la zone 30

Celle-ci est un peu particulière, car la topologie est en Full Mesh.

 

Voici comment configurer R3 :

R3(config)#interface serial 0/1
R3(config-if)#no shutdown
R3(config-if)#encapsulation frame-relay

 

R3(config)#interface serial 0/1.1 multipoint
R3(config-subif)#ip address 172.16.30.3 255.255.255.0
R3(config-subif)#frame-relay map ip 172.16.30.7 307 broadcast
R3(config-subif)#frame-relay map ip 172.16.30.8 308 broadcast

 

R7 est à configurer comme ceci :

R7(config)#interface serial 0/0
R7(config-if)#no shutdown
R7(config-if)#encapsulation frame-relay

 

R7(config-if)#interface serial 0/0.1 multipoint
R7(config-subif)#ip address 172.16.30.7 255.255.255.0
R7(config-subif)#frame-relay map ip 172.16.30.3 703 broadcast
R7(config-subif)#frame-relay map ip 172.16.30.8 708 broadcast

 

R8 est à configurer comme ceci :

R8(config)#interface serial 0/0
R8(config-if)#no shutdown
R8(config-if)#encapsulation frame-relay

 

R8(config-if)#interface serial 0/0.1 multipoint
R8(config-subif)#ip address 172.16.30.8 255.255.255.0
R8(config-subif)#frame-relay map ip 172.16.30.3 803 broadcast
R8(config-subif)#frame-relay map ip 172.16.30.7 807 broadcast

 

Il ne reste plus qu’à tester avec des requêtes de Ping

Ping vers R7

Et voilà, votre topologie est maintenant prête !

De plus, vous savez exactement comment elle fonctionne (configuration Frame Relay, etc…)

 

3)     Configuration d’OSPF

 

Zone 0 : NBMA

Cette zone est du type NBMA. Il n’est donc pas possible d’y faire transiter des Broadcast et des Multicast.

Même en activant les pseudos Broadcast (ce que nous avons fait), cela ne permettra pas d’établir les relations de voisinages.

Nous allons donc mettre en place OSPF, puis nous créerons les relations de voisinages à la main.

 

La configuration de base n’a rien de nouveau.

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 172.16.0.1 0.0.0.0 area 0

 

Encore une fois, libre à vous de choisir l’ID que vous voulez. Pour plus de simplicité dans ce Lab, nous choisissons une ID qui reflète le nom du routeur.

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 172.16.0.2 0.0.0.0 area 0
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 172.16.0.3 0.0.0.0 area 0

 

Comme vous pouvez le constater, aucune relation de voisinage n’a été créée

R1 OSPF Neighbor Table

Pour corriger le problème, il faut renseigner les adresses des voisins sur R1. Seulement sur R1, car c’est le seul qui est directement relié à tous les autres routeurs (R2 et R3). Il jouera donc le rôle de DR.

 

R1(config-router)#neighbor 172.16.0.2
R1(config-router)#neighbor 172.16.0.3

 

Et maintenant, les relations sont apparues :

R1 Logs

 

Malheureusement, il y a un problème :

R1 OSPF Neighbor Table

Ce n’est pas R1 qui est le DR. Or, comme dit précédemment, c’est à lui d’assurer ce rôle.

C’est le seul à pouvoir redistribuer les MAJ, car c’est le seul à être connecté à tout le monde.

 

Il faut donc s’assurer que R2 et R3 ne puisse pas devenir DR ou BDR :

R2(config)#interface serial 0/0
R2(config-if)#ip ospf priority 0

 

R3(config)#interface serial 0/0
R3(config-if)#ip ospf priority 0

 

Automatiquement, les rôles vont être redistribués

R1 OSPF Neighbor Table

R2 OSPF Neighbor Table

R1 est devenu le DR, car par défaut, il a une priorité de 1.

R2 et R3 étant à 0, ils ne peuvent pas participer à l’élection.

 

Et voilà, notre zone NBMA est configurée !

 

Zone 10 : Point to Multipoint

Cette zone va être configurée en Point to Multipoint.

Pour rappel, dans ce mode de fonctionnement d’OSPF, il n’y a pas d’élection de DR / BDR, et les relations de voisinage se font de manière automatique.

Cela est dû au fait qu’en Point to Multipoint, les liens fonctionneront de manière similaire à des liens Point to Point.

 

Mettons déjà en place une configuration de base pour OSPF

R1(config)#router ospf 1
R1(config-router)#network 172.16.10.1 0.0.0.0 area 10

 

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 172.16.10.4 0.0.0.0 area 10
R4(config-router)#network 10.10.0.0 0.0.3.255 area 10

 

R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 172.16.10.5 0.0.0.0 area 10

Voilà.

Maintenant, il faut passer en mode Point to Multipoint.

R1(config)#interface serial 0/1
R1(config-if)#ip ospf network point-to-multipoint

 

R4(config)#interface serial 0/0
R4(config-if)#ip ospf network point-to-multipoint

 

R5(config)#interface serial 0/0
R5(config-if)#ip ospf network point-to-multipoint

 

Faisons quelques vérifications sur R1

R1 OSPF Neighbor Table

Les relations sont bien établies. Vous pouvez d’ailleurs constater qu’il n’y a pas de DR / BDR.

R1 Routing Table

Les relations sont OK, et les routes ont été distribuées. Cette zone est parfaitement configurée !

 

Vous pouvez aussi constater que les routes se propagent en dehors de la zone.

 

Jetez un œil sur R3 :

R3 Routing Table

 

Pour réduire la taille des tables de routage, ajoutons un peu de route Summarization

R1(config-router)#area 10 range 10.10.0.0 255.255.252.0

 

Zone 10 : Point to Multipoint NonBroadcast

Avant de passer à la zone Point to Point, voyons une configuration alternative pour cette zone.

Nous avons vu que ne mode NonBroadcast peut être utilisé si les routeurs ne supportent pas les pseudos Broadcast (au niveau de la commande « frame relay map »).

Désactivons donc les Pseudos Broadcast (afin de tester ce mode) :

 

R1(config)#interface serial 0/1
R1(config-if)#frame-relay map ip 172.16.10.4 104
R1(config-if)#frame-relay map ip 172.16.10.5 105

 

R4(config)#interface serial 0/0
R4(config-if)#frame-relay map ip 172.16.10.1 401
R4(config-if)#frame-relay map ip 172.16.10.5 401

 

R5(config)#interface serial 0/0
R5(config-if)#frame-relay map ip 172.16.10.1 501
R5(config-if)#frame-relay map ip 172.16.10.4 501

 

Vous pourrez constater, sur R1, que les relations de voisinage ont disparu.

 

Passons le tout en mode NonBroadcast

R1(config)#interface serial 0/1
R1(config-if)#ip ospf network point-to-multipoint non-broadcast

 

R4(config)#interface serial 0/0
R4(config-if)#ip ospf network point-to-multipoint non-broadcast

 

R5(config)#interface serial 0/0
R5(config-if)#ip ospf network point-to-multipoint non-broadcast

 

Aucune relation n’apparait. C’est normal, les Hello ne peuvent plus transiter.

Il faut donc ajouter les voisins à la main.

R1(config)#router ospf 1
R1(config-router)#neighbor 172.16.10.4
R1(config-router)#neighbor 172.16.10.5

 

Et maintenant, les relations de voisinage sont de retour :

R1 OSPF Neighbor Table

De plus, les routes vers les interfaces de Loopback de R4, sont à nouveau présentes :

R1 Routing Table

Et voilà !

Vous avez vu la variante du Point to Multipoint.

 

Zone 20 : Point to Point

Cette zone est à configurer en mode Point to Point.

Pour plus de simplicité, elle ne comporte que deux routeurs.

 

La configuration est très simple.

R2(config)#router ospf 1
R2(config-router)#network 172.16.20.2 0.0.0.0 area 20

 

R6(config)#router ospf 1
R6(config-router)#router-id 6.6.6.6
R6(config-router)#network 172.16.20.6 0.0.0.0 area 20
R6(config-router)#network 10.20.0.0 0.0.3.255 area 20

 

Et c’est tout !

Vous pouvez constater que la relation est apparue :

R6 OSPF Neighbor Table

 

Les routes de R6 vers 10.20.0.0 /22 sont bien présentes dans la table de routage de R2 :

R2 Routing Table

Il n’est pas nécessaire de configurer plus, car les liens sont déjà considérés comme étant en Point to Point (cf configuration Frame Relay).

 

Par contre, vous pouvez ajouter du résumé de route :

R2(config)#router ospf 1
R2(config-router)#area 20 range 10.20.0.0 255.255.252.0

 

Zone 30 : Broadcast

Finissons par la zone de Broadcast.

Les relations devraient se faire automatiquement, et il devrait y a voir une élection DR / BDR.

Pour rappel, la topologie est Full Mesh. Chaque routeur à un DLCI vers les autres routeurs.

 

Commençons par une configuration d’OSPF.

R3(config)#router ospf 1
R3(config-router)#network 172.16.30.3 0.0.0.0 area 30

 

R7(config)#router ospf 1
R7(config-router)#router-id 7.7.7.7
R7(config-router)#network 172.16.30.7 0.0.0.0 area 30
R7(config-router)#network 10.30.0.0 0.0.3.255 area 30

 

R8(config)#router ospf 1
R8(config-router)#router-id 8.8.8.8
R8(config-router)#network 172.16.30.8 0.0.0.0 area 30

 

Profitez-en pour active le résumé de route

R3(config)#router ospf 1
R3(config-router)#area 30 range 10.30.0.0 255.255.252.0

 

Une fois cela fait, il faut passer en mode Broadcast :

R3(config)#interface serial 0/1.1
R3(config-subif)#ip ospf network broadcast

 

R7(config)#interface serial 0/0.1
R7(config-subif)#ip ospf network broadcast

 

R8(config)#interface serial 0/0.1
R8(config-subif)#ip ospf network broadcast

 

Nous pouvons voir sur R3, que les relations de voisinage sont apparues, et qu’une élection DR/BDR a eu lieu :

R3 OSPF Neighbor Table

 

Au passage, vous pouvez constater que les timers Hello et Dead sont bien à 10 et 40 :

R8 OSPF Interface

 

Vérifications

Maintenant que toutes les zones ont été configurées, il ne reste plus qu’à vérifier que tout fonctionne.

Voyons si R1 connait toutes les routes :

R1 Routing Table

Oui, il connait bien toutes les routes !

Vous pouvez faire de même sur tous les routeurs, vous verrez que les routes sont bien propagées.

Profitez-en pour faire quelques Ping

Ping vers R1

 

4)     Conclusion

 

Enfin, nous avons terminé !

La configuration de ces 5 modes aura été longue.

Vous savez donc maintenant comment mettre en place les différents modes.

Bien sûr, il faut faire un choix parmi les 5.

Cela dépendra de la topologie, de vos préférences, etc…

Quel que soit le choix, vous devriez être en mesure de vous adapter !

N’hésitez pas à revenir sur certaines configurations, ou sur la théorie.

Il est important d’avoir les idées claires sur ces 5 modes (comment fonctionnent-ils et comment se configurent-ils).

Tagués avec : ,
Publié dans OSPF

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.