OSPF : Configuration Basique

Comment configurer le protocole OSPF sur un réseau ?

Nous allons voir cela dans cet article.

Après une mise en place basique d’OSPF, nous verrons comment mettre en place de la Summarization et de la redistribution de route.

La configuration basique n’a rien de compliqué. Nous verrons par la suite des notions plus délicates.

 

 

1)     Configuration  d’OSPF

 

1.1 Topologie

Voici la topologie :

Topologie OSPF

Le réseau est divisé en 3 zones. Les routeurs R2, R6, R4 et R5 ont des interfaces de Looback, symbolisant des réseaux reliés aux routeurs.

R1 possède des routes statiques. Il servira à simuler une connexion vers d’autres réseaux.

Le but est de mettre en place l’OSPF dans les 3 zones, et de rendre les réseaux accessibles depuis tous les routeurs.

 

1.2 Area 0

Commençons par configurer R1 :

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 172.16.1.1 0.0.0.0 area 0
R1(config-router)#network 172.16.2.1 0.0.0.0 area 0

Le numéro « 1 » après la commande « routeur OSPF », correspond au processus ID.

Il a une signification locale.

Cala permet d’activer plusieurs processus OSPF sur le routeur. Nous utiliserons toujours « 1 ».

 

Ici, nous avons choisi de configurer le routeur ID à la main. Bien entendu, nous aurions pu laisser OSPF le choisir.

Libre à vous de choisir une IP adéquate. Pour la simplicité de ce TP, nous choisirons une IP qui représente le nom du routeur.

 

Dans les commandes « Network », j’ai choisi de fournir directement l’IP de l’interface.

Ensuite, il faut indiquer le numéro de la zone.

 

Faisons de même sur les autres routeurs.

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 172.16.1.2 0.0.0.0 area 0
R2(config-router)#network 172.16.3.2 0.0.0.0 area 0
R2(config-router)#network 10.0.0.0 0.0.3.255 area 0

 

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 172.16.3.3 0.0.0.0 area 0
R3(config-router)#network 172.16.2.3 0.0.0.0 area 0

 

Vérifions que les relations de voisinage sont bonnes :

R1 OSPF Neighbor Table

 

Puis, vérifions la table de routage :

R1 Routing Table

R1 peut voir les réseaux qui sont connectés à R2.

Jusqu’ici tout semble bon !

 

1.2 Area 20

Faisons le lien avec l’area 20.

Pour cela, revenons sur R2.

Il faut le connecter à la zone.

R2(config)#router ospf 1
R2(config-router)#network 172.16.20.2 0.0.0.0 area 20

 

Faisons de même sur R6 :

R6(config-router)#network 172.16.20.6 0.0.0.0 area 20
*Mar  1 00:15:07.051: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done

Nous pouvons directement voir que la relation est passée à l’état FULL

 

Il faut encore dire à R6 d’agir sur les réseaux 10.20.0.0 /22

R6(config-router)#network 10.20.0.0 0.0.3.255 area 20

 

Plaçons nous sur R3 pour voir si il connait les routes pour 10.20.0.0 /22

R2 Routing Table

En effet, R3 qui est dans la zone 0, et qui n’est pas directement connecté à R6, connait les routes pour 10.20.2.0 /22

Les routes possèdent le tag « IA ». Cela veut dire que c’est une route vers une autre area.

 

Autre chose à noter, R3 a choisi R1 comme Next Hop, au lieu de R2. Cela est dû au fait que la bande passante est meilleure du côté de R1 (ce qui est normal, car R2 – R3 est un lien série).

 

Nous pouvons aussi voir la métrique de cette route : 85.

 

Les plus attentifs d’entre vous, aurons surement remarqué que nous avons oublié de configurer quelque chose sur R6.

R2 OSPF Neighbor Table

Il s’agit du router ID.

 

R6 est donc identifié par sa plus haute IP de Loopback.

Libre à vous de laisser comme ça, ou de modifier le router ID.

Voici comment le modifier :

R6(config-router)#router-id 6.6.6.6
Reload or use "clear ip ospf process" command, for this to take effect

Comme nous l’indique le routeur, il faut remettre à zéro le process OSPF.

R6#clear ip ospf process
Reset ALL OSPF processes? [no]: y

Attention, cette commande va provoquer une interruption de service. En effet, les relations avec les voisins vont être coupées pendant quelques secondes.

 

R2 a bien pris connaissance du nouvel ID de R6 :

R2 OSPF Neighbor Table

 

1.2 Area 10

Passons à quelque chose de plus intéressent. Vous l’aurez deviné, dans la zone 10 les rôles DR / BDR vont entrer en jeu.

 

Mettons en place la configuration de base que vous connaissez bien.

R3(config)#router ospf 1
R3(config-router)#network 172.16.10.3 0.0.0.0 area 10

 

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 172.16.10.4 0.0.0.0 area 10
R4(config-router)#network 10.10.0.0 0.0.3.255 area 10

 

R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 172.16.10.5 0.0.0.0 area 10
R5(config-router)#network 10.10.4.0 0.0.3.255 area 10

 

Vérifions les relations de voisinage :

R4 OSPF Neighbor Table

R4 voit bien ses voisins. De plus R3 est le DR.

 

Si l’on souhaite forcer un routeur à devenir le DR, il suffit de changer sa priorité :

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip ospf priority 200

 

Par défaut la priorité est à 1.

Une priorité de 0 signifie que le routeur ne peut pas devenir le DR / BDR

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip ospf priority 0

 

Pour que le statut DR / BDR change, il faut réinitialiser le process OSPF.

R3#clear ip ospf process

 

1.4 Vérification

Si vous avez bien suivi les étapes, vous pourrez constater que tous les routeurs connaissent toutes les routes.

Voyons R1 :

R1 Routing Table

En plus des liens entre les routeurs et des routes statiques, R1 connais les réseaux 10.10.0.0 /22, 10.20.0.0 /22, 10.0.0.0 /22.

 

Jusqu’ici, tout est bon !

 

Mais ne trouvez-vous pas que la table de routage est un peu chargée ?

Mettons en place de la Route Summarization pour arranger les choses.

 

1.5 Route Summarization

Le résumé de route fonctionne de manière un peu particulière en OSPF.
Il doit être mis en place sur les ABR – Area Border Router.

Par exemple, pour résumer les routes de l’area 20, il faut utiliser R2.

Pour la zone 10, il faut se placer sur R3.

 

Voyons comment faire.

R2(config)#router ospf 1
R2(config-router)#area 20 range 10.20.0.0 255.255.252.0

Ainsi, R2 annoncera une route résumée pour 10.20.0.0 /22.

Vérifions cela sur R3 :

R3 Routing Table

La table de routage est tout de suite plus simple non ?

 

Faisons de même pour la zone 10.

R3(config)#router ospf 1
R3(config-router)#area 10 range 10.10.0.0 255.255.248.0

 

Puis vérifions sur R1 :

R1 Routing Table

Pour le coup, la table est vraiment plus petite !

 

1.6 Redistribution de route

Vous vous demandez surement ce que nous allons faire des routes statiques sur R1, non ?

Nous avions dit qu’elles symbolisent une connexion vers d’autres réseaux (non représentées sur le schéma).

Comme les routes existent déjà, il faut les redistribuer.

OSPF sera chargé de dire aux autres routeurs que R1 connais des routes vers des réseaux externes.

 

La configuration est relativement simple :

R1(config)#router ospf 1
R1(config-router)#redistribute static subnets metric 200 metric-type 2

 

Voici ce que signifient les mots clés :

  • Subnet : le routeur va redistribuer les réseaux classfull et classless (sans le mot clé « subnet », si nous avions une route 182.168.2.0 /27, elle ne serait pas redistribuée)
  • Metrci 200 : les routes auront une métrique de 200
  • Metric-type 2 : la métrique n’évolue pas quand la route est redistribuée entre les routeurs (cad que R2 aura une métrique de 200 pour 192.168.0.0 /22, pareil pour R6)

 

Deux articles complets sont dédiés à la redistribution : http://www.networklab.fr/category/ccnp_routing/route-redistribution/

Vous pouvez les consulter si vous souhaitez plus de détails sur la théorie et la pratique.

 

Constatons le résultat :

R2 Routing Table

R2 a connaissance des routes externes.

De plus, la métrique n’a pas augmenté.

 

Mais vous ne trouvez pas qu’il y a un problème ? La table de routage a encore grandi ….

 

Encore un peu de Summarization et on n’en parle plus !

R1(config)#router ospf 1
R1(config-router)#summary-address 192.168.0.0 255.255.252.0

Ce type de résumé ne peut se faire que sur un ASBR – Autonomous System Border Router. C’est-à-dire, un routeur qui faire le lien avec un autre AS. En l’occurrence R1.

 

Et voilà le résultat !

R2 Routing Table

1.7 Calcul du coût

Pour finir, attardons nous un peu sur le calcul de coût en OSPF.

Nous avons vu que le coût d’un lien représente sa bande passante.

Voici la correspondance :

  • Lien Série 56 Kbps : 1785
  • Lien série T1 1.544 Mbps : 64
  • Lien Ethernet 10 Mbps : 10
  • Lien FastEthernet : 1
  • Lien Gigabit Ethernet : 1

 

La métrique d’une route est en fait l’addition de tous les coûts des liens entre le routeur est la destination.

 

Mais vous avez surement remarqué que le coût ne diminue plus après les liens FastEthernet.

 

En effet, le protocole OSPF a été inventé il y a plus de 20 ans. A l’époque, il était impensable d’arriver à des liens si rapides.

 

Pour corriger le problème, et que les liens Gigabits soient bien pris en compte, il faut changer le calcul du coût.

 

Voici comment faire :

R3(config)#router ospf 1
R3(config-router)#auto-cost reference-bandwidth 1000

 

Ainsi, les liens Gigabit auront un coût de 1, et les liens FastEthernet un coût de 10.

Attention, cette configuration est à appliquer sur tous les routeurs.

 

2)     Résumé

Faisons un dernier tour sur ce que l’on a vu.

Nous avons vu comment configurer les routeurs de manière basique :

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 172.16.1.1 0.0.0.0 area

 

Nous avons vu que les routes circulent entre les Area, et qu’elles sont marquées comme externes

Exemple sur R3 :

R3 Routing Table

Nous avons vu comment fonctionnent les relations DR / BDR, et comment influencer l’élection

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip ospf priority 200

(une priorité de 0 empêche le routeur de devenir DR / BDR)

 

Puis nous avons vu comment résumer les routes entre les zones :

R2(config)#router ospf 1
R2(config-router)#area 20 range 10.20.0.0 255.255.252.0

 

Nous avons aussi vu comment redistribuer les routes venant d’un autre protocole de routage (ou des routes statiques) :

R1(config)#router ospf 1
R1(config-router)#redistribute static subnets metric 200 metric-type 2

 

Nous avons vu comment résumer ces routes (sur l’ASBR) :

R1(config)#router ospf 1
R1(config-router)#summary-address 192.168.0.0 255.255.252.0

 

Enfin, nous avons vu comment changer le calcul du coût, si notre réseau comporte des liens supérieurs au FastEthernet :

R3(config)#router ospf 1
R3(config-router)#auto-cost reference-bandwidth 1000
Tagués avec : , ,
Publié dans OSPF
2 commentaires pour “OSPF : Configuration Basique
  1. Bwaze dit :

    Encore un très bon article.
    Juste une petite remarque, il faudrait peut-être ajouter des explications sur le metric-type et montrer la différence entre les metric-type 1 et 2.

    • Valentin Weber dit :

      Bonjour, merci pour le compliment.
      En effet, je n’ai pas donné beaucoup d’explication sur la redistribution. J’en ai profité pour insérer un lien vers les deux articles dédiés à la redistribution que j’ai rédigé.
      De nombreux détails sont disponibles dans ces articles.
      Merci pour le commentaire.

1 Pings/Trackbacks pour "OSPF : Configuration Basique"

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.