Configuration Des Différents Types De Zones OSPF

Après avoir vu la théorie des zones OSPF, voyons la pratique.

Nous allons voir comment configurer les différentes zones détaillées dans l’article précédent.

Nous ne reviendrons que très peu sur la théorie. Il est donc important de maitriser les bases.

 

1)     La topologie

 

Voici la topologie qui sera utilisée dans cet article. Il s’agit de la même que dans l’article précédent.

Topologie OSPF

 

1)     Configuration Basique

 

Avant de passer à la configuration des zones, mettons en place la configuration basique.

Premièrement, appliquez les IP indiquées sur les interfaces associées.

Une fois cela fait, il faut configurer le protocole OSPF.

Voici la procédure :

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.12.1 0.0.0.0 area 0
R1(config-router)#network 10.0.13.1 0.0.0.0 area 0

 

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.0.12.2 0.0.0.0 area 0
R2(config-router)#network 10.0.23.2 0.0.0.0 area 0
R2(config-router)#network 10.40.1.2 0.0.0.0 area 40
R2(config-router)#network 10.50.1.2 0.0.0.0 area 50

 

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 10.0.13.3 0.0.0.0 area 0
R3(config-router)#network 10.0.23.3 0.0.0.0 area 0
R3(config-router)#network 10.60.1.3 0.0.0.0 area 60

 

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 10.40.1.4 0.0.0.0 area 40
R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)#network 10.50.1.5 0.0.0.0 area 50

 

R6(config)#router ospf 1
R6(config-router)#router-id 6.6.6.6
R6(config-router)#network 10.60.1.6 0.0.0.0 area 60
R6(config-router)#network 10.70.1.6 0.0.0.0 area 70

 

R7(config)#router ospf 1
R7(config-router)#router-id 7.7.7.7
R7(config-router)#network 10.70.1.7 0.0.0.0 area 70

 

Configurons R1 comme un ASBR :

R1(config)#ip route 172.16.0.0 255.255.255.0 Null0
R1(config)#ip route 172.16.1.0 255.255.255.0 Null0
R1(config)#ip route 172.16.2.0 255.255.255.0 Null0
R1(config)#ip route 172.16.3.0 255.255.255.0 Null0

 

R1(config)#router ospf 1
R1(config-router)#redistribute static subnets metric-type 1 metric 200

 

Vérifions que les routes externes sont bien redistribuées et que les routes des zones voisines sont bien accessibles :

R2 Routing Table

 

Deux articles complets sont dédiés à la redistribution : http://www.networklab.fr/category/ccnp_routing/route-redistribution/

Vous pouvez les consulter si vous souhaitez plus de détails sur la théorie et la pratique.

 

Bien, la configuration de base est faite.

Les relations OSPF sont en place et toutes les zones sont en mode standard.

Actuellement, les LSA de types 3, 4 et 5 peuvent transiter librement entre les zones.

Il va donc falloir mettre en place les zones vues dans l’article précédent.

Autre chose que nous allons devoir traiter : la zone 70.

Si vous avez été attentifs, vous aurez surement remarqué que la zone 70 n’est pas directement reliée à la zone 0.

Cela est contraire aux principes des zones.

Ce type de topologie ne doit pas être mis en place dans une bonne architecture.

 

Mais si pour une bonne raison vous devez mettre en place ce type de topologie (une zone reliée à la zone 0 par une autre zone), il faudra utiliser un « Virtual Link ».

Sans cela, la zone 70 sera isolée du reste.

 

Voyons cela, avant de passer aux différents types de zone.

 

3)     Virtual Link

 

Comme dit précédemment, le Virtual Link permet de relier la zone 70 à la zone 0 et ce de manière virtuelle.

 

Pour l’instant, le routeur R7 est totalement isolé (malgré sa relation avec R6).

R7 Routing Table

La configuration du Virtual Link est très simple :

 

R3(config)#router ospf 1
R3(config-router)#area 60 virtual-link 6.6.6.6

 

R6(config)#router ospf 1
R6(config-router)#area 60 virtual-link 3.3.3.3

 

Voyons si R7 est moins seul :

R7 Routing Table

En effet, c’est comme si il était connecté à la zone 0.

 

4)     Stubby Area 

 

Attaquons le vif du sujet en commencent pas la Stubby Area.

Pour rappel, son but est d’empêcher les LSA de type 4 et 5 de rentrer (et de circuler) dans la zone.

Nous allons mettre cela en place pour la zone 40.

R4 n’aura donc plus les routes externes (172.16.0.0 /22) mais une route par défaut pointant vers R2.

 

La configuration est très simple :

 

R2(config)#router ospf 1
R2(config-router)#area 40 stub

 

R4(config)#router ospf 1
R4(config-router)#area 40 stub

 

Vérifions si les routes externes ont bien été remplacées par une route par défaut :

R4 Routing Table

En effet !

 

Vous pouvez aussi constater que R4 ne possède plus de LSA de type 4 et 5 dans sa base de données :

R4 OSPF Database

 

Les LSA de types 4 et 5 s’arrêtent à R2. La même commande sur ce dernier vous permettra de voir les LSA de types 4 et 5.

 

Il est à noter que tous les routeurs de la zone 40 doivent être en mode Stub.

 

5)     Totally Stubby Area

 

Comme dit dans le précédent article, le but de cette zone est d’empêcher le transit des LSA de types 3, 4 et 5.

Le routeur ne connaitra que les routes internes à sa zone. Les autres seront remplacées par une route par défaut.

Voyons cela pour la zone 50 :

 

R2(config)#router ospf 1
R2(config-router)#area 50 stub no-summary

 

R5(config)#router ospf 1
R5(config-router)#area 50 stub

 

Vérifions la table de routage :

R5 Routing Table

Parfait, il ne reste plus que les / la route interne.

Un petit coup d’œil à la base de données pour être sûr :

R5 OSPF Database

 

6)     Not So Stubby Area 

 

Pour ce type de zone, réutilisons la zone 40.

Mais avant toutes choses, retirons la configuration actuelle :

Vous pouvez aussi essayer de conserver la configuration Stub puis de configurer la redistribution. Un message d’erreur vous dira qu’il n’est pas possible de configurer la redistribution dans une zone Stub (voir article précédent).

 

R4(config)#router ospf 1
R4(config-router)#no area 40 stub

 

R2(config)#router ospf 1
R2(config-router)#no area 40 stub

 

Puis, ajoutons des routes statiques sur R4 :

 

R4(config)#ip route 172.18.0.0 255.255.255.0 Null 0
R4(config)#ip route 172.18.1.0 255.255.255.0 Null 0
R4(config)#ip route 172.18.2.0 255.255.255.0 Null 0
R4(config)#ip route 172.18.3.0 255.255.255.0 Null 0

 

Mettons en place la redistribution :

R4(config)#router ospf 1
R4(config-router)#redistribute static subnets metric 200 metric-type 1

 

Si vous consultez les tables de routage des autres routeurs, vous verrez que les routes ont été redistribuées.

 

Passons maintenant cette zone en Not So Stubby :

R2(config)#router ospf 1
R2(config-router)#area 40 nssa

 

R4(config)#router ospf 1
R4(config-router)#area 40 nssa

 

Normalement, à ce stade, R4 devrait être capable de redistribuer les routes 172.18.0.0 /22 vers le reste de la topologie.

Vérifions sur R3 :

R3 Routing Table

R3 a bien connaissance des routes !

Mais est ce que R4 fonctionne toujours comme un routeur Stub (c’est-à-dire qu’il ne reçoit pas les routes redistribuée) ?

R4 Routing Table

En effet, il ne possède pas les routes redistribuées (cad 172.16.0.0 /22).

On garde les avantages du mode Stub, tout en permettant la redistribution de route depuis l’intérieure de la zone.

Parfait non ?

Presque. Vous n’avez rien remarqué dans la table de routage de R4 ?

Oui, il manque bien la route par défaut !

R4 sera donc incapable de joindre les réseaux 172.16.0.0 /22.

En mode NSS, R2 n’annonce pas de route par défaut.

Pas de soucis, il y a une solution :

R2(config)#router ospf 1
R2(config-router)#area 40 nssa default-information-originate

 

Retour sur R4 :

R4 Routing Table

Et voilà !

R4 et en mode Stubb (ou plutôt NSS) et permet la redistribution de route.

 

Si vous êtes curieux, je vous invite à aller consulter les bases de données OSPF des différents routeurs, et voir quels types de LSA elles contiennent.

 

7)     Totally Stubby Not So Stubby Area 

 

Le principe est le même que pour le mode NSS.

Ici nous gardons les avantages du mode Totally Stubby (pas de LSA de types 3, 4 et 5), mais nous avons la possibilité de redistribuer des routes.

Il n’y a qu’une seule commande à changer.

(Bien entendu, il faut d’abord annuler la configuration précédente)

R2(config-router)#area 40 nssa no-summary

Voici à quoi ressemble alors la table de routage de R4 :

R4 Routing Table

 

8)     Conclusion

 

Et bien voilà, nous avons vu comment mettre en place une configuration OSPF avec des zones.

Nous avons d’abord vu l’utilité d’un Virtual Link.

Pour rappel, voici sa configuration :

R3(config)#router ospf 1
R3(config-router)#area 60 virtual-link 6.6.6.6

 

R6(config)#router ospf 1
R6(config-router)#area 60 virtual-link 3.3.3.3

 

Ensuite, nous avons vu comment configurer une Stubby Area :

R2(config)#router ospf 1
R2(config-router)#area 40 stub

 

R4(config)#router ospf 1
R4(config-router)#area 40 stub

 

Puis nous avons vu la Totally Stubby Area

R2(config)#router ospf 1
R2(config-router)#area 50 stub no-summary

 

R5(config)#router ospf 1
R5(config-router)#area 50 stub

Par après, nous avons vu la Not So Stubby Area :

R2(config)#router ospf 1
R2(config-router)#area 40 nssa
R2(config-router)#area 40 nssa default-information-originate

 

R4(config)#router ospf 1
R4(config-router)#area 40 nssa

 

Et enfin, la Totally Stubby Not So Stubby Area :

R2(config-router)#area 40 nssa no-summary

 

Tagués avec : , , ,
Publié dans OSPF
6 commentaires pour “Configuration Des Différents Types De Zones OSPF
  1. hamed dit :

    Bonjour, c’est propre voire même très propre mais il y’a une chose que je n’arrive pas à bien assimiler;c’est au niveau des zones. C’est de là que vient ma principale préoccupation. je souhaiterais que vous m’éclaircissiez un peu plus la-dessus si vous ne voyiez pas d’inconvénients.

  2. hamed dit :

    C’est au niveau des zones. Comment saviez-vous que telle zone est stuby ou nssa ou encore stub ?

    Puis que signifie le fait de mettre NULL 0 devant une route statique ?

    • Valentin Weber dit :

      Le type de zone à mettre en place est un choix.
      Pour connaitre les spécificités de chaque type de zone OSPF, je vous renvoie à l’article les détaillant.

      En fonction du réseau et de nos attentes, nous pourrons choisir de mettre en place telle ou telle zone.

      Quant au NULL0, lors-ce-qu’il est utilisé comme destination d’une route statique, il permet de droper le trafic routé par la route.
      Le NULL0 est ici simplement utilisé à titre d’exemple, pour créer de fausses routes statiques (pour les besoins de la démonstration).

      Il n’est en aucun cas nécessaire de mettre en place des routes statiques vers Null0, pour une configuration de zone OSPF.

  3. hamed dit :

    Bonsoir merci pour toute l’aide que vous m’apportez, et aussi votre disponibilité. Est-ce qu il est possible que l’on discute en temps réel ? Car je souhaite plus participer à vos TP.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Le temps imparti est dépassé. Merci de saisir de nouveau le CAPTCHA.